To ensure best experience, it is recommended to follow the official WordPress requirement list that can be found here: WordPress requirements.

While currently PHP 7 (PHP version 5.6 is also good) and HTTPS support is not mandatory, we recommend to consider upgrading to experience superior performance and security.

For your convenience we also provide server info details on Appearance/Theme Dashboard page: